Two Library Sites currently down

Incident Report for TAMU Technology Services IT

Resolved

This issue has been resolved and both websites should be operating as intended. If you have any additional problems or concerns regarding this incident, please contact the Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for more assistance.
Posted Apr 29, 2025 - 17:10 CDT

Investigating

The library catalog site - catalog.library.tamu.edu and the Cushing archival management system site -https://findingaids.library.tamu.edu/) are currently giving a 504 Bad Gateway error when trying to log in. Admins are aware of the issue and investigating. No ETR
Posted Apr 29, 2025 - 15:18 CDT
This incident affected: General Services.