Aggieworks errors when looking up workorders.

Incident Report for TAMU Technology Services IT

Resolved

This issue has been resolved. If you have any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Nov 23, 2025 - 22:21 CST

Investigating

Some users are reporting receiving errors when submitting work orders . Technicians have been paged. No ETR at this time.
Posted Nov 23, 2025 - 21:11 CST
This incident affected: Administrative & Business (AggieWorks).