Adobe Document Cloud Sign In Degradation

Incident Report for TAMU Technology Services IT

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 00:02 CDT

Monitoring

Adobe has indicated that this issue is resolved; however, it may still take a bit longer to log in than standard. Admins will continue to monitor performance but if you have any related issues in the meantime, please reach out to Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for additional assistance.
Posted Mar 23, 2026 - 16:36 CDT

Investigating

Administrators have reported that sign in time is delayed when logging into Adobe Document Cloud. The vendor is aware of the issue and currently working on a fix.

If you believe you are experiencing issues related to this event, please contact Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for further assistance.
Posted Mar 23, 2026 - 11:11 CDT
This incident affected: Administrative & Business (Adobe Sign).