Power outage near intersection of George Bush & Penberthy.

Incident Report for TAMU Technology Services IT

Resolved

Facilities confirmed that power has been restored at these locations.

If you have any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Mar 24, 2026 - 14:50 CDT

Investigating

Facilities has confirmed that there is a power outage affecting several buildings near the intersection of George Bush & Penberthy, Affected buildings include:

1556 - Penberthy Intramural Sports Center
1582 - West Campus Player Development Center
1583 - Davis Diamond Softball Stadium,
1584 - E.B. Cushing Stadium
1586 - Penberthy South Restroom
1587 - Penberthy South Control Building
1612 - Brookshire Brothers

Facilities has dispatched electricians to work on the issue. At present, there is no Estimated Time to Resolution.
Posted Mar 24, 2026 - 08:06 CDT
This incident affected: General Services.