Microsoft login issues with DUO

Incident Report for TAMU Technology Services IT

Resolved

From DUO: The issue causing 504 gateway timeouts during Microsoft Entra logins when Duo MFA was called has been fully resolved. Authentication services are operating normally at this time. https://status.duo.com/incidents/byd2vdlp1rff

If you believe you are still experiencing issues related to this event, please contact Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.
Posted Feb 23, 2026 - 11:52 CST

Monitoring

The DUO Administrators have deployed a fix for the gateway timeouts and are now seeing successful authentications. We are currently monitoring for any further issues.
Posted Feb 23, 2026 - 10:44 CST

Update

The following services may be affected:

Microsoft Applications
Howdy
Canvas
Google Workspace
Team Dynamix

This may include other applications that use Entra and DUO for multifactor authentication. Thank you for your patience as we continue to investigate.
Posted Feb 23, 2026 - 09:40 CST

Update

DUO has notified our admins that they are currently investigating an issue where 504 Gateway timeouts are present when accessing Entra when Duo is called for MFA.

https://status.duo.com/incidents/byd2vdlp1rff
Posted Feb 23, 2026 - 09:19 CST

Investigating

Campus Members are reporting Microsoft login issues that use DUO for authentication. We are coordinating with venders and investigating. Thank you for you patience.
Posted Feb 23, 2026 - 08:59 CST
This incident affected: Core Services (Duo Multi-Factor Authentication, Microsoft 365).