Verizon Cellular Network Outage

Incident Report for TAMU Technology Services IT

Resolved

Verizon has declared that the outage has been resolved. If customers are still encountering issues they are encouraged to restart their devices to reconnect to the network.

If you believe any TAMU related service is still being impacted by this outage, please reach out to Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.
Posted Jan 14, 2026 - 21:57 CST

Investigating

Administrators have reported that Verizon is having a large-scale outage affecting subscribers nationally. Vendors are working to resolve the issue. Verizon users on campus may be affected. There is no current estimated time to restoration.
Posted Jan 14, 2026 - 14:26 CST
This incident affected: Core Services (Phones and Cellular).