Power Outage Affecting Hensel Park Area

Incident Report for TAMU Technology Services IT

Resolved

Power has been restored and reported as stable for the area.

If you currently have any additional problems or questions, please reach out to Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.
Posted Dec 02, 2025 - 08:30 CST

Monitoring

Support teams have reported that all areas are back on utility power. We will continue to monitor the situation.

If you have any questions or concerns regarding this event please contact the Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.
Posted Dec 02, 2025 - 03:59 CST

Identified

Reports as of 1:50 AM indicate that Hensel-1 is on primary power, though a transformer that supplies Hensel-2 is being rewired. Hensel-2 is on backup power. KAMU has reported they are back online. We do not presently have an estimated time to resolution.
Posted Dec 02, 2025 - 02:11 CST

Investigating

Facilities & Energy Services are currently reporting a power outage impacting the Hensel Park area of Campus. Multiple services and buildings have been impacted by this outage including but not limited to:

- Gardens Apartments
- Bus Operations Dispatch
- UPD Dispatch
- Some KAMU Services

Other services may be impacted currently and will be updated as information becomes available. Facilities & Energy Services have dispatched technicians to the area to address this issue. There is currently no ETR for this power outage.

If you have additional information in regards to impacted services, please contact the Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.
Posted Dec 01, 2025 - 23:16 CST
This incident affected: General Services.