Microsoft 365 Degradation

Incident Report for TAMU Technology Services IT

Resolved

Microsoft update:

"Final status: We’ve confirmed that the affected infrastructure has returned to a healthy state and is operating as expected. We’ll continue to closely monitor the remediation actions taken and make any necessary adjustments to maintain stability. If users experience any residual issues, clearing local DNS caches or temporarily lowering DNS TTL values may help ensure updates are reflected more quickly."
Posted Jan 23, 2026 - 01:45 CST

Monitoring

Microsoft is confident that the incident is largely resolved. Access to Microsoft Defender for Office, Microsoft Purview, and DNS functionality has been restored, and Exchange Online mail flow remains stable. Microsoft continues to fine tune load balancing adjustments while closely monitoring the impacts of recent changes to support sustained recovery.

Several services, such as mail delivery and reception, may still be slow or show delays but as queues continue to process services should return to normal.

If you believe you are still experiencing complications from this vendor degradation, please reach out to Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.

Microsoft continues to provide updates on their own Status Page here: https://status.cloud.microsoft/
Posted Jan 22, 2026 - 23:58 CST

Update

Improvements are now being seen from Microsoft services, however, services still may be intermittent.

Microsoft aims to provide further updates regarding their remediation efforts at 9:30PM CST.
Posted Jan 22, 2026 - 20:35 CST

Update

Microsoft continues to refine their load balancing configurations to remedy residual imbalances across the environment and further ongoing recovery efforts.

Microsoft aims to provide further updates at 7:30PM CST.
Posted Jan 22, 2026 - 18:25 CST

Update

Microsoft continues to work towards a resolution for this degradation.

Microsoft aims to provide further updates regarding their remediation efforts at 6:30PM CST.
Posted Jan 22, 2026 - 17:38 CST

Investigating

Microsoft has reported a service degradation within the Microsoft 365 environment. This issue may impact Texas A&M faculty, staff, and students, specifically regarding:

Email delivery and receipt
Access to service portals
Administrative functions

We will provide updates as we receive them from Microsoft.

https://status.cloud.microsoft/
Posted Jan 22, 2026 - 15:40 CST
This incident affected: Core Services (Microsoft 365).