Power Outage - Business Management Services Building (Building #3099)

Incident Report for TAMU Technology Services IT

Resolved

Power has been restored and network devices are back online. If you have any further issues regarding this incident, please report them to Help Desk Central at 979-845-8300, or by email at helpdesk@tamu.edu.
Posted Aug 26, 2025 - 08:54 CDT

Investigating

Administrators are reporting a power outage in the Business Management Services Building (building 3099), per College Station Utilities. More information about this event can be found at https://outages.cstx.gov/
Posted Aug 26, 2025 - 08:27 CDT
This incident affected: Core Services (TAMU Campus Internet Connectivity).