TTDN - TAMU Central Texas - Tarleton State University Lumen Circuit is down

Incident Report for TAMU Technology Services IT

Resolved

Vendor technicians have completed repairs on the damaged fiber in Killeen, Tx.

If you have additional questions or concerns, please reach out to Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.
Posted Mar 31, 2026 - 21:26 CDT

Update

The provider has almost completed repairs on the damaged fiber in Killeen, Tx. Current ETR is approximately 30 minutes. TTDN services remain functional due to the architecture of the network infrastructure.
Posted Mar 31, 2026 - 19:04 CDT

Update

A vendor technician is currently on site repairing the damaged fiber in Killeen, Tx. There is no current ETR regarding the damaged fiber, however TTDN services remain functional due to the architecture of the network infrastructure.
Posted Mar 31, 2026 - 17:33 CDT

Update

The provider has discovered a fiber cut in Killeen Tx. A repair team has been dispatched. The estimated time of repair is 4 hours. Connectivity to this location remains available due to the redundant architecture of the network.
Posted Mar 31, 2026 - 14:24 CDT

Update

The provider is still investigating this issue with no estimated time to restoration. TTDN services remain operational due to the Architecture of WAN infrastructure.
Posted Mar 31, 2026 - 12:24 CDT

Identified

Provider has detected a fault in the fiber line and they are working on repairing it with no estimated time to restoration, TTDN services remain operational due to the Architecture of WAN infrastructure.
Posted Mar 31, 2026 - 09:58 CDT

Investigating

TAMU Central Texas - Tarleton State University Lumen Circuit is down. Engineers are investigating the issue.

For any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Mar 31, 2026 - 06:03 CDT
This incident affected: Infrastructure (TTDN).