Power Outage Affecting Multiple Buildings

Incident Report for TAMU Technology Services IT

Resolved

Facilities has reported that power has been restored to these buildings.
Posted Feb 01, 2026 - 11:13 CST

Investigating

Administrators have confirmed that multiple buildings are experiencing a power outage including Francis Hall, Thompson Hall, the Reed-McDonalds Building and the Engineering Innovation Center. This issue is expected to have been caused by a downed feeder distributing power to these areas.

Technicians are currently enroute to assess the issue. There is currently no estimated time to resolution.
Posted Feb 01, 2026 - 08:59 CST
This incident affected: General Services.