AggieMap Recovery

Incident Report for TAMU Technology Services IT

Resolved

Administatros have confirmed that this maintenance is now complete
Posted Mar 17, 2026 - 14:38 CDT

Monitoring

Maintenance has concluded as of 12:50 AM, Aggie Maps is currently online and we will continue to monitor functionality.
Posted Mar 17, 2026 - 01:25 CDT

Identified

The AggieMap service will be temporarily unavailable while we perform maintenance to restore the system to a previous known working configuration. We apologize for the inconvenience and appreciate your patience.

More updates will be provided as they become available. If you have any questions or concerns in the meantime, please reach out to Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.
Posted Mar 16, 2026 - 19:08 CDT
This incident affected: General Services.