TTDN - TTI San Antonio Castle Hills is down

Incident Report for TAMU Technology Services IT

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 14:05 CDT

Investigating

Texas A&M Transportation Institute at San Antonio Castle Hills is down. Engineers are investigating the issue.
Posted Jul 14, 2025 - 12:35 CDT
This incident affected: Infrastructure (TTDN).