Beutel Health Center Phone Line Busy

Incident Report for TAMU Technology Services IT

Resolved

Administrators have implemented a fix which has resolved the issue. The Beutel Health Center phone line 979 458 8310 is now available.

For any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Oct 27, 2025 - 10:09 CDT

Investigating

Administrators have received reports that the Beutel Health Center phone line: 979 458 8310, immediately goes to busy upon dialing. Administrators are currently investigating this issue.
Posted Oct 27, 2025 - 10:00 CDT
This incident affected: Core Services (Phones and Cellular).