Degradation in email routing within TDX-Incoming email addresses

Incident Report for TAMU Technology Services IT

Resolved

Technology Services has addressed all outstanding emails and has been actively monitoring all mailboxes for ticket creation. The IT Service Management Office will continue to monitor and adjust for any emails that do not behave as expected. A full review of routing rules and architecture will be performed to ensure the issue does not arise again.

If you are still experiencing any issues or have any further questions, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for further assistance.
Posted Aug 18, 2025 - 12:45 CDT

Update

Technology Services has identified and reached out to all 242 customers affected by this issue. Any affected campus members with outstanding requests will have their tickets prioritized.

Active monitoring of the TeamDynamix ticket ingestion email addresses has been established, the root cause investigation is still ongoing.
Posted Aug 12, 2025 - 13:59 CDT

Monitoring

The Technology Services Service Management Office was recently made aware of an issue within Exchange mailboxes supporting TeamDynamix that affected a percentage of email requests being read into TeamDynamix. These emails did not generate a ticket as expected and, therefore, were not addressed. This issue appears to have affected approximately 500 tickets. The Service Management Office has begun actively monitoring the incoming mailboxes for any additional issues.

The issue appears to be isolated to the Technology Services TeamDynamix application and does not impact our other Campus partners utilizing TeamDynamix for departmental enterprise service management work.

While the team is looking into the cause of this issue, we are actively working to respond to and address the unresolved requests. As a result, Technology Services teams may start seeing these older requests routed to their ticket queues. These support requests should be treated as high priority, as we seek to address and resolve them as quickly as possible. The team will be focusing on requests made within the last 30 days and then those received more than 30 days ago.
Posted Aug 08, 2025 - 17:13 CDT

Update

Investigations continue by admins and the Service Management Office.
Posted Aug 08, 2025 - 16:00 CDT

Update

Admin investigations are still ongoing.
Posted Aug 08, 2025 - 14:49 CDT

Update

We are continuing to investigate this issue.
Posted Aug 08, 2025 - 10:32 CDT

Update

We are continuing to investigate this issue.
Posted Aug 08, 2025 - 10:20 CDT

Investigating

Teamdynamix is experiencing an intermittent issue in routing some email requests to the correct service groups. Admins are currently investigating. An estimated time to resolution may be made available once impact is assessed.
Posted Aug 08, 2025 - 10:10 CDT
This incident affected: IT Professional Services (Service.tamu.edu).