Email notifications from Microsoft 365 Services Being Throttled

Incident Report for TAMU Technology Services IT

Resolved

After further investigation by our Microsoft 365 administrators, they have confirmed that the mentioned delay is very minor and the number of users affected is small and the issue can be considered resolved.

If you continue to experience issues with a Microsoft service, please contact the Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for further assistance.
Posted Mar 19, 2026 - 10:54 CDT

Investigating

User impact: Emails that are generated by interacting with products within Microsoft 365 may experience an indefinite delay when being sent to users.

More info:

The affected email notifications may include but are not limited to the following examples:
- File sharing email notifications for OneDrive for Business, or Microsoft 365 apps
- Site sharing email notifications for SharePoint Online
- News post notifications within SharePoint Online
- Comments, mentions in Office documents

Current status: Microsoft monitoring has detected unusual spikes in notification activity in your tenant. In order to protect users, our automated systems have disabled email notifications that are generated through interaction with products in Microsoft 365.

More information will be posted as it becomes available. If you believe you are experiencing troubles relating to this Microsoft Service Alert, please reach out to Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.

Additional information: If you are an administrator, you can see more details in the Microsoft 365 admin center regarding MO1255294
Posted Mar 18, 2026 - 18:52 CDT
This incident affected: Core Services (Microsoft 365).