TTDN - TAMU West Campus Data Center - Dallas Fidium Circuit is Down.

Incident Report for TAMU Technology Services IT

Resolved

Administrators have confirmed that this incident is now resolved and all systems are functioning as expected.

For any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Aug 12, 2026 - 15:42 CDT

Monitoring

Our engineers have rerouted traffic as vendors have stated repairs are expected to take over the weekend. Further updates will be forthcoming on Monday.

For any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Aug 07, 2026 - 13:07 CDT

Update

Engineers have partially restored connectivity by rerouting network traffic.

For any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Aug 06, 2026 - 15:44 CDT

Update

Fiber crews are on site but repairs are expected to take a few days. We will continue to update this status with progress as it becomes available to us.

For any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Aug 06, 2026 - 14:37 CDT

Identified

Fiber repair crews are expected on-site this afternoon.
Posted Aug 06, 2026 - 07:36 CDT

Update

Provider is investigating. There is no estimated time to restoration.
Posted Aug 05, 2026 - 12:45 CDT

Investigating

TAMU West Campus Data Center - Dallas Fidium Circuit is Down. Engineers are investigating the issue. Primary services are operational via backup path.

For any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Aug 05, 2026 - 12:26 CDT
This incident affected: Infrastructure (TTDN).