Technology Services is aware of ongoing issues affecting email delivery to Microsoft consumer domains, including Outlook.com, Live.com, Hotmail.com, and MSN.com. This is a global issue impacting multiple organizations. Microsoft is actively investigating the cause.
According to Microsoft’s official announcement:
"We are aware of an issue that may result in certain IP addresses being temporarily rejected at higher rates. We are actively investigating the issue. Please continue to submit tickets if you are experiencing this problem."
As a result, messages sent to these domains may experience delays or temporary rejections. Our mail servers will continue to retry undelivered messages for up to five days. No action is required from users at this time. This issue is not unique to Texas A&M.
Administrators are in communication with Microsoft and are monitoring ongoing recovery efforts. We will provide additional updates as new information becomes available.
Posted Mar 02, 2026 - 09:37 CST
Monitoring
After implementing a fix, administrators have confirmed that there has been significant improvement to delivery results of these services. Administrators are still working with the vendor at this time to determine the root cause of this issue. We will continue to monitor this service for stability and provide additional updates as they become available.
For questions or further assistance, please contact Texas A&M Technology Services – Help Desk Central at 979‑845‑8300 or helpdesk@tamu.edu.
Posted Feb 27, 2026 - 15:38 CST
Investigating
Messages sent from our mail server to recipients on Outlook.com, Live.com, Hotmail.com, and Msn.com are currently being temporarily rate limited due to IP reputation. As a result, outbound emails to these addresses may be delayed in delivery. The system will continue retrying undelivered messages for up to 5 days. No user action is required at this time, but email delivery to Outlook.com, Live.com, Hotmail.com, and Msn.com may be impacted until reputation issues are resolved.
For questions or further assistance, please contact Texas A&M Technology Services – Help Desk Central at 979‑845‑8300 or helpdesk@tamu.edu.
Posted Feb 25, 2026 - 08:25 CST
This incident affects: Core Services (Campus Email).