TTDN - TAMUCT-TSU Lumen circuit is down

Incident Report for TAMU Technology Services IT

Resolved

Service restored at 10:35.
Posted May 19, 2025 - 10:41 CDT

Investigating

TAMUCT-TSU Lumen redundant circuit is down. Engineers are investigating the issue. Primary services are operational via backup path.
Posted May 19, 2025 - 08:38 CDT
This incident affected: Infrastructure (TTDN).