Power Outage Affecting Multiple Buildings

Incident Report for TAMU Technology Services IT

Resolved

Power has successfully been restored to the affected buildings. If you are still experiencing any technical issues as a result of this power outage, please reach out to Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu to report the issue.
Posted Feb 02, 2026 - 22:53 CST

Update

We are continuing to work on a fix for this issue.
Posted Feb 02, 2026 - 02:21 CST

Identified

Administrators have confirmed that multiple buildings are experiencing a electrical outage including Harrington Education Center Office, Harrington Education Center Classroom, Academic Building. This issue seems to have been caused by a downed feeder distributing power to these areas. Technicians are currently enroute to assess the issue.
Posted Feb 02, 2026 - 01:51 CST
This incident affected: General Services.