TTDN - East TAMU Houston Peoples Circuit is down.

Incident Report for TAMU Technology Services IT

Resolved

The circuit has been back up since approximately 3:50PM and has remained stable. TTDN services should not have been affected by this fiber cut, however, if you have additional questions or concerns, please reach out to Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.
Posted Feb 18, 2026 - 20:15 CST

Identified

Circuit outage is due to a fiber cut in the Dallas area. There is no estimated time of repair at this time. TTDN services are not affected due to the WAN architecture providing alternate paths.
Posted Feb 18, 2026 - 10:46 CST

Investigating

East TAMU Houston Peoples Circuit is down. Engineers are investigating the issue.

For any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Feb 18, 2026 - 08:09 CST
This incident affected: Infrastructure (TTDN).