Network Devices Down at the Health Science Center in Bryan

Incident Report for TAMU Technology Services IT

Resolved

Network connectivity has been restored to the building and the devices.

For any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Oct 29, 2025 - 09:59 CDT

Update

UES has identified the issue and is now waiting for the City of Bryan to arrive onsite. There is no current ETR
Posted Oct 28, 2025 - 14:22 CDT

Update

UES is on site investigating an electrical issue.
Posted Oct 28, 2025 - 08:42 CDT

Identified

Administrators have received a report that multiple networking devices at the Health Science Center in Bryan are down. Field technicians have determined this is a power issue and are currently working on implementing a fix.
Posted Oct 27, 2025 - 15:32 CDT
This incident affected: Core Services (TAMU Campus Internet Connectivity).