Google Cloud and Workspace are experiencing a widespread outage

Incident Report for TAMU Technology Services IT

Resolved

Google has confirmed that all impacted services have returned to normal operations. All Texas A&M Services that relied on Google's operation should be working as intended, however if you continue to experience issues or have additional questions or concerns, please contact the Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for more assistance.
Posted Jun 12, 2025 - 20:35 CDT

Update

Google reports that the problem with Gmail, Google Calendar, Google Chat, Google Cloud Search, Google Docs, Google Drive, Google Meet, Google Tasks, and Google Voice has been resolved (Google Workspace). The Google Cloud issue has not been reported as resolved yet.
Posted Jun 12, 2025 - 15:53 CDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 14:32 CDT

Investigating

Google Cloud and Workspace are currently experiencing a widespread outage:

Multiple GCP products are experiencing impact due to Identity and Access Management Service Issue

for more information, see:
https://status.cloud.google.com/
https://www.google.com/appsstatus/dashboard/
Posted Jun 12, 2025 - 14:25 CDT
This incident affected: General Services.