TAMU_VISITOR Network Connection Degradation

Incident Report for TAMU Technology Services IT

Resolved

TAMU_VISITOR should once again be working as intended. If you continue to have problems connecting to this network, please reach out to Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for additional assistance.
Posted Jan 20, 2026 - 22:48 CST

Investigating

Campus Members may experience issues with connecting to the TAMU_VISITOR network where the page to verify connection fails to load completely or continues to refresh constantly.

Network admins are aware and are investigating the cause of this issue.

In the meantime, if you have any additional questions or concerns, please contact Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.
Posted Jan 20, 2026 - 16:14 CST
This incident affected: Core Services (TAMU Campus Internet Connectivity).