Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 06, 2025 - 20:00 CDT
Scheduled
Begin Time: Friday, June 6th - 8pm End Time: Monday, June 23rd - 11:59pm
Details of Maintenance: Texas A&M University will begin implementing storage limits for Microsoft OneDrive and SharePoint accounts on Friday, June 6. The rollout will occur in phases and most customers should see their new quotas by Monday, June 23. This change was originally scheduled for May 18, but implementation took longer than expected.
All account holders will have ample data storage available and should not see any interruption in day-to-day activities with OneDrive or SharePoint sites. You should have received an email with your new quota a few weeks ago.
Change ID: 230958
Posted Jun 05, 2025 - 19:34 CDT
This scheduled maintenance affected: Core Services (Microsoft 365).