Unable To Connect To The Hub

Incident Report for TAMU Technology Services IT

Resolved

Administrators have reported that this issue has been resolved.

If you believe you are still experiencing issues related to this event, please contact Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.
Posted Mar 23, 2026 - 09:43 CDT

Update

We are continuing to investigate this issue.
Posted Mar 23, 2026 - 06:29 CDT

Investigating

Reports have been received stating that www.thehub.tamu.edu is currently down and Transportation team is actively investigating to resolve this issue.

If you believe you are still experiencing issues related to this event, please contact Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.
Posted Mar 23, 2026 - 06:19 CDT
This incident affected: General Services.