TTDN - Bush School (DC) is down

Incident Report for TAMU Technology Services IT

Resolved

Resolved. All circuits and devices are online.
Posted Jul 12, 2025 - 05:58 CDT

Identified

A power outage had been scheduled for Friday July 11th beginning at 10:00 PM EST in order to perform maintenance on building electrical systems. This outage affects the entire building and is scheduled to last approximately until 10:00 AM EST.
Posted Jul 11, 2025 - 22:14 CDT

Investigating

Bush School DC is down. Engineers are investigating the issue.

Additionally, the Bush School DC to Dallas Cogent as well as the Bush School DC to Houston circuits are down. Impact to primary services are currently being investigated by engineers.
Posted Jul 11, 2025 - 21:34 CDT
This incident affected: Infrastructure (TTDN).