swan.tamu.edu website Availability

Incident Report for TAMU Technology Services IT

Resolved

The issue has been resolved. The site is working properly. If you have any issues or need assistance please contact Help Desk Central at 979.845.8300
Posted Jun 17, 2025 - 12:27 CDT

Investigating

Our Admins are currently investigating an issue reported for Campus members seeing an application error when accessing the Study Abroad website:

swan.tamu.edu/educationabroad
Posted Jun 17, 2025 - 12:09 CDT
This incident affected: General Services.