ISSS Portal

Incident Report for TAMU Technology Services IT

Resolved

This issue has been resolved.
Posted May 17, 2025 - 14:40 CDT

Update

A high priority ticket has been submitted to the vendor. There is no estimated time of repair currently.
Posted May 17, 2025 - 12:41 CDT

Identified

A system error may appear in some sections of the International Student & Scholar Services website. Customers have reported issues when clicking on the "Documents" icon and links such as "changes of status" leads to a system error message. Technicians have been notified and are actively working to resolve this issue.
Posted May 17, 2025 - 12:33 CDT
This incident affected: General Services.