TTDN - TDEM El Paso is down

Incident Report for TAMU Technology Services IT

Resolved

Texas Division of Emergency Management - El Peso WAN services are back up. There was a power outage in the building.

If you are still experiencing issues or have additional questions or concerns, please contact the Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu with any questions or concerns.
Posted Jan 22, 2026 - 16:19 CST

Investigating

Texas Division of Emergency Management - El Peso WAN services are down. Engineers are investigating the issue.

Please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu with any questions or concerns.
Posted Jan 22, 2026 - 15:28 CST
This incident affected: Infrastructure (TTDN).