TTDN - Dallas-Lumen-Commodity-ISP is Down

Incident Report for TAMU Technology Services IT

Resolved

This incident has been resolved.
Posted Feb 05, 2026 - 14:20 CST

Monitoring

A fix has been implemented and TTDN services for this circuit has been restored. We will continue to monitor the stability of this fix throughout the day.
Posted Feb 05, 2026 - 11:53 CST

Update

Provider is investigating. TTDN services are available due to network architecture providing alternate paths.
Posted Feb 05, 2026 - 11:17 CST

Investigating

Dallas-Lumen-Commodity-ISP is Down. Engineers are investigating the issue.

For any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Feb 05, 2026 - 11:17 CST
This incident affected: Infrastructure (TTDN).