TTDN - PSC-Corpus_Christi is Down

Incident Report for TAMU Technology Services IT

Resolved

Circuit has been back up since 11:05am.
Posted Jan 15, 2026 - 12:58 CST

Investigating

PSC-Corpus_Christi is Down. Engineers are investigating the issue.

For any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Jan 15, 2026 - 10:48 CST
This incident affected: Infrastructure (TTDN).