Lumen and the local carrier have confirmed repair of the fiber cut as of 7:32PM.
Service has remained stable, however, if you have additional questions or concerns in regards to this issue, please contact the Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for further assistance.
Posted Jul 02, 2025 - 20:21 CDT
Update
The carrier is still working with the Local Exchange Carrier to facilitate repairs. No ETR.
Posted Jul 02, 2025 - 15:53 CDT
Identified
Lumen has referred to the issue to a local carrier. The local carrier has identified a fiber cut, there is currently no estimated time of repair.
Posted Jul 02, 2025 - 12:24 CDT
Update
Lumen is still actively investigating the issue. No ETR.
Posted Jul 02, 2025 - 10:27 CDT
Update
LUMEN is not seeing any light from the Dallas side of the circuit. They are investigating the issue. No ETR.
Posted Jul 02, 2025 - 07:42 CDT
Investigating
The ETAMU Dallas Lumen circuit is down. Engineers are investigating the issue. Primary services are operational via backup path.