Jamf Outage

Incident Report for TAMU Technology Services IT

Resolved

Services have remained stable and Jamf has confirmed all issues related to the global outage have been resolved.
Posted Apr 16, 2025 - 17:03 CDT

Update

All services have remained stable. We will continue to monitor and provide updates until Jamf confirms the global outage is resolved.
Posted Apr 16, 2025 - 08:37 CDT

Update

We are continuing to monitor for any further issues.
Posted Apr 15, 2025 - 18:17 CDT

Monitoring

Access to the Jamf Self-Service Hub on managed Apple devices is restored. Engineers will continue to monitor and provide updates until Jamf confirms the global outage is resolved.
Posted Apr 15, 2025 - 18:17 CDT

Identified

Engineers have been alerted of a global Jamf issue preventing managed Apple devices from accessing the Self-Service Hub. Jamf has identified the issue and currently working on implementing a fix but there is no estimated time of resolution. Updates will be provided regularly until service is restored.
Posted Apr 15, 2025 - 17:36 CDT
This incident affected: General Services.