AggieWorks Service Degradation

Incident Report for TAMU Technology Services IT

Resolved

AggieWorks AiM was restored at 3:21 AM and administrators have monitored this service for continued stability, determining that this event was resolved upon service restoration.

If you believe you are still experiencing issues related to this event, please contact Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.
Posted Feb 24, 2026 - 09:34 CST

Monitoring

AggieWorks AiM service has currently been restored, support teams will monitor the service performance.
Posted Feb 24, 2026 - 03:21 CST

Update

We are continuing to investigate this issue.
Posted Feb 24, 2026 - 03:09 CST

Investigating

Reports have been received stating that AggieWorks(AiM) is currently down and EAM team is actively investigating to resolve the service degradation currently impacting performance for AggieWorks AiM. There is currently no estimated time of resolution.
Posted Feb 24, 2026 - 03:09 CST
This incident affected: General Services.