Go Work Management Classic App Showing Blank Screen

Incident Report for TAMU Technology Services IT

Resolved

Administrators have confirmed that this issue is localized to only a few SSC users and is not an outage or degradation of the service. It is believed that this issue is related to users who do not yet have accounts or account passwords may have expired. These isolated cases will be handled by the SSC directly.

If you are continuing to experience issues with the Go Work Management App, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Feb 05, 2026 - 11:15 CST

Investigating

Administrators have received multiple reports of users seeing a blank screen after attempting to log in to the Go Work Management app. Service owners have confirmed that the Go Work Management app is operating as normal and are investigating the root cause of the issue.

A follow-up update for this issue will be posted within the next hour.

For any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Feb 05, 2026 - 10:34 CST
This incident affected: General Services.