AI Builder Credit Degradation

Incident Report for TAMU Technology Services IT

Resolved

AI Builder service is restored. If you experience any issues, please contact Help Desk Central at 979.845.8300
Posted Jun 18, 2025 - 08:45 CDT

Update

Communications are ongoing with Microsoft regarding this issue. No ETR at this time.
Posted Jun 17, 2025 - 16:55 CDT

Update

Technicians are still investigating the issue.
Posted Jun 16, 2025 - 13:19 CDT

Monitoring

We are currently experiencing an issue with the Power Automate AI Builder service. As a result, users may encounter errors when attempting to utilize AI Builder functionalities.

Our team is actively working to resolve this issue and assessing potential impacts on other workflows. We are collaborating with Microsoft to expedite the resolution and restore full functionality.
Posted Jun 16, 2025 - 12:37 CDT
This incident affected: General Services.