TTDN - ETAMU-Mesquite is Down

Incident Report for TAMU Technology Services IT

Resolved

This circuit is now up and functionality has been restored
Posted Mar 18, 2026 - 15:03 CDT

Monitoring

Engineers have completed onsite repair and are verifying functionality of the network.
Posted Mar 18, 2026 - 14:30 CDT

Update

A ticket has been submitted to the provider. Provider is now investigating.
Posted Mar 18, 2026 - 11:04 CDT

Investigating

ETAMU-Mesquite is Down. Engineers are investigating the issue.

For any further questions or concerns, please contact the Texas A&M Technology Services Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu.
Posted Mar 18, 2026 - 10:23 CDT
This incident affected: Infrastructure (TTDN).