TeamDynamix Error

Incident Report for TAMU Technology Services IT

Resolved

The vendor has implemented a solution and this issue is now resolved. If you have any additional problems or questions, please reach out to Technology Services' Help Desk Central at 979.845.8300 or at helpdesk@tamu.edu for continued assistance.
Posted Dec 05, 2025 - 20:57 CST

Investigating

There's a current issue with TeamDynamix that gives users an error when attempting to access tickets. This is a vendor side issue and being investigated. Updates will be posted as they become available.
Posted Dec 05, 2025 - 20:33 CST
This incident affected: IT Professional Services (Service.tamu.edu).